Itential Dependencies
  • 17 Jan 2024
  • Dark
    Light
  • PDF

Itential Dependencies

  • Dark
    Light
  • PDF

Article Summary

This page presents a consolidated list of software dependencies for each IAP release, along with product release notes for both Itential Automation Platform (IAP) and Itential Automation Gateway (IAG).

IAP Release Notes

⚠ EOS Notice

IAP 2021.2 End of Support Date: January 24, 2024. See Version Lifecycle for more information.

IAG Release Notes

Host Operating System

IAP is supported on the following operating systems.

IAP Version Operating System Release Production Development
2023.1 RHEL 64-Bit RHEL 8
RHEL 9
x x
2023.1 Rocky 64-Bit Rocky 8
Rocky 9
x x
2022.1 RHEL 64-Bit RHEL 8 x x
2021.2 RHEL 64-Bit RHEL 7 x x
2021.2 CentOS 64-Bit CentOS 7 x x
2021.1 RHEL 64-Bit RHEL 7 x x
2021.1 CentOS 64-Bit CentOS 7 x x

Automation Platform Server

IAP Version nodejs python pip MarkupSafe (pip package) textfsm Jinja2
2023.1 >=18.15.0 <19.0.0 >=3.9.5 >=20.2.4 2.0.1 >=1.1.2 <1.2.0 >=2.11.3 <2.12.0
2022.1 16.20.1 or 14.18.0** (EOL) 3.9 >=20.2.4 2.0.1 >=1.1.2 <1.2.0 >=2.11.3 <2.12.0
2021.2 16.20.1 or 14.18.0** (EOL) 3.9 >=20.2.4 2.0.1 >=1.1.2 <1.2.0 >=2.11.3 <2.12.0
2021.1 16.20.1 or 14.18.0** (EOL) 3.9 >=20.2.4 2.0.1 1.x 2.x

Notes:
- The gcc-c++ and make packages should be installed from your OS distribution.
- Jinja2 depends on the MarkupSafe module.

** Node version 14.18.0 is compatible with the indicated release versions; however, this version of Node is EOL (end of life) and Itential does not recommend or support its use. Itential recommends Node 16.20.1 for the IAP versions indicated.

MongoDB Server

IAP Version MongoDB
2023.1 5.0 or 6.0
2022.1 5.0 or 6.0
2021.2 5.0 or 6.0
2021.1 5.0 or 6.0

RabbitMQ Server

IAP Version rabbitmq erlang elixir / dedup plugins
2023.1 >=3.11.10 <3.12.0 RabbitMQ Erlang/OTP Event Deduplication
2022.1 3.11.7 RabbitMQ Erlang/OTP Event Deduplication
2021.2 3.11.7 RabbitMQ Erlang/OTP Event Deduplication
2021.1 3.11.7 RabbitMQ Erlang/OTP Event Deduplication

Redis Server

IAP Version Redis Server
2023.1 >=7.0.0 < 7.1.0
2022.1 6.2.10
2021.2 6.2.10
2021.1 6.2.10

Note: The gcc-c++ and make packages should be installed from your OS distribution.

HashiCorp Vault

IAP Version Vault
2023.1 >=1.13.1 <2.0.0
2022.1 >=1.0.0 <2.0.0
2021.2 >=1.0.0 <2.0.0
2021.1 1.x

Itential supports the use of a variety of third-party integrations to further enhance the capabilities of Itential Automation Platform (IAP). Cisco Network Services Orchestrator (NSO) is one such integration. To ensure that NSO functions as intended, it is important to understand which NSO versions are supported for each IAP version. This document provides information to help you determine which version of NSO is compatible with your IAP environment.

Automation Gateway

IAG Version python openssl haproxy pip terraform nornir netmiko
2023.2 3.9.x >=1.1.0 <=1.2.0 >=2.0.0 <3.0.0 20.2.4 1.2.9 >=3.0.0 <4.0.0 4.1.2
2023.1 3.9.x >=1.1.0 <=1.2.0 >=2.0.0 <3.0.0 20.2.4 1.2.9 >=3.0.0 <4.0.0 4.1.2
2022.1 >=3.9.5 <4.0.0 >=1.1.0 <=1.2.0 >=2.0.0 <3.0.0 20.2.4 >=0.12.0 <0.13.0 >=3.0.0 <4.0.0 >=3.0.0 <4.0.0
2021.2 >=3.9.5 <4.0.0 >=1.1.0 <=1.2.0 >=2.0.0 <3.0.0 20.2.4 >=0.12.0 <0.13.0 >=3.0.0 <4.0.0 >=3.0.0 <4.0.0
2021.1 3.9 1.x 2.x 20.2.4 0.12.x 3.x 3.x

Notes:
- The gcc-c++ and make packages should be installed from your OS distribution.
- The following development packages are required to install Automation Gateway: libffi-dev, openssl-dev, python-dev, sqlite-dev.
- One or more of the following packages may be required by the specific Ansible modules you're using: psutil, pycrypto, paramiko, ncclient, lxml, nitrosdk-python, jxmlease.
- Check the Ansible documentation for the roles you're planning to use for additional package requirements.

Ansible

IAG Version ansible ansible core ansible community
2023.2 >= 2.9.0 < 2.11.0 >= 2.13.0 < 2.15 >= 6.0 < 8.0
2023.1 >= 2.9.0 < 2.11.0 >= 2.13.0 < 2.15 >= 6.0 < 8.0
2022.1 >= 2.9.0 < 2.11.0
2021.2 >= 2.9.0 < 2.11.0
2021.1 2.9 or 2.10

Notes:
- Prior to IAG 2023.1, Itential supported ansible up to version 2.10.
- Ansible changed its versioning after 2.10 to release both the ansible-core and ansible-community packages.
- Check the Ansible release documentation for details.

NSO / Itential Tools

IAP Version Package Supported
2023.1 java >=1.70 <1.9.0
2022.1 java >=1.70 <1.9.0
2021.2 java >=1.70 <1.9.0
2021.1 java 1.7 or 1.8

Note: The ant package should be installed from your OS distribution.


NSO Support Policy

The Itential platform supports integration with tested and verified versions of NSO, which may vary for each version of IAP. To this end, Itential will address any errors or flaws that affect the integration of supported NSO versions into IAP. All patch releases (denoted by the third digit in the NSO version number) for supported NSO versions are covered by this policy.

⚠ Itential is not responsible for the development or support of NSO itself.

Versions Currently Supported

Supported versions of NSO are defined in the Release Notes of each version of IAP. In the Devices/Services Compatibility section of the release notes, the NSO versions used for testing are listed in the NSO Versions table. When viewing this table, note that the support policy defined above applies. Though a specific patch release for each NSO version may be listed in the table, any patch release for that NSO version is supported.

⚠ When planning to integrate NSO into IAP, keep long-term support (LTS) versions of NSO in mind. Details regarding the support of LTS versions of NSO can be found in the next section.

Planned Future Support

The following sections outline planned support for NSO that Itential is targeting for the future. As new versions of IAP and NSO are released, testing will be required before certifying support.

Aligning With Cisco Support

Moving forward, Itential will support any version of NSO that is supported by Cisco at that time, including LTS versions of NSO. For further information about the NSO version lifecycle, refer to the Cisco End-of-Life and End-of-Sale Notices.

Backporting Support

Whenever a new version of NSO is released by Cisco, Itential will attempt to certify support of that NSO version for the latest existing release of IAP.

NSO Version Support Matrix

Version 2021.2.x 2022.1.x 2022.2.x 2023.1.x 2023.2.x 2024.1.x 2024.2.x 2025.1.x 2025.2.x
5.5.x
5.6.x
5.7.x (LTS)
5.8.x [1] ✓ [2]
6.0.x [1] ✓ [2]
6.1.x (LTS) [1] ✓ [2]
6.2.x [1] ✓ [2]
6.3.x [1] ✓ [2]

Footnotes

[1] NSO version numbers that are forecasted for release in the future are subject to change.

[2] IAP support for this future version of NSO will be backported once the NSO version is released by Cisco.


Was this article helpful?

Changing your password will log you out immediately. Use the new password to log back in.
First name must have atleast 2 characters. Numbers and special characters are not allowed.
Last name must have atleast 1 characters. Numbers and special characters are not allowed.
Enter a valid email
Enter a valid password
Your profile has been successfully updated.