Release Notes

On this page:

2021.2.3 Maintenance Release

2021.2.3 Maintenance Release [2022-04-05]

Changelog Overview

  • 2 New Features
  • 10 Improvements
  • 68 Bug Fixes
  • 5 Security Fixes
  • 14 Chores
  • 7 Tests
  • 106 Total Tickets

New Features

  • app-workflow_engine:9.12.7-2021.2.28 [03-16-2022] - Added support for HTTP and HTTPS proxies to the restCall task.
  • pronghorn-core:13.15.17-2021.2.56 [03-24-2022] - Added support for HTTP and HTTPS proxies to integration calls.

Improvements

  • adapter-azure_aaa:1.3.2-2021.2.5 [03-15-2022] - Added support for HTTP and HTTPS proxies.
  • app-admin_essentials:3.5.64-2021.2.34 [03-08-2022] - Updated the Banner component to use rodeo-ui.
  • app-configuration_manager:3.90.10-2021.2.21 [02-23-2022] - Fixed tooltips for buttons in the GC tree header.
  • app-json_forms:1.33.5-2021.2.6 [02-24-2022] - Added examples to methods.
  • app-workflow_builder:5.44.8-2021.2.15 [03-18-2022] - Updated the run window styling for Gen 1 workflows.
  • pronghorn-core:13.15.17-2021.2.55 [03-23-2022] - Updated licensing module to add proxy support.
  • pronghorn-core:13.15.17-2021.2.49 [03-17-2022] - Added support for basic authentication of HTTPS proxies.
  • pronghorn-core:13.15.17-2021.2.48 [03-17-2022] - Added support for proxies with self-signed certificates.
  • pronghorn-core:13.15.17-2021.2.44 [03-15-2022] - Added the current time and timezone to the getStatus API.
  • pronghorn-core:13.15.17-2021.2.39 [03-09-2022] - Improved logs for the crash/restart service by removing spamming and reducing the number of logs.

Bug Fixes

  • adapter-automation_gateway:4.24.1-2021.2.4 [03-24-2022] - Added an exactMatch option to the input parameter of getDevicesFiltered to differentiate the details for devices with a similar name but different IP addresses.
  • adapter-nso:7.8.2-2021.2.7 [03-23-2022] - Fixed a bug that caused Config Manager to incorrectly render (return) a device IP Address. This fix uses XPath to directly fetch the exact device details.
  • app-admin_essentials:3.5.64-2021.2.36 [03-17-2022] - Repo configs can only be saved after being changed.
  • app-admin_essentials:3.5.64-2021.2.35 [03-17-2022] - Updated Rodeo to the latest version.
  • app-admin_essentials:3.5.64-2021.2.33 [03-08-2022] - Fixed an issue that prevented config changes to the Pre-built repository from being saved.
  • app-admin_essentials:3.5.64-2021.2.31 [02-24-2022] - Updated the button bar styling.
  • app-admin_essentials:3.5.64-2021.2.30 [02-23-2022] - Changed the direction of the paginator dropdown. All page options are now selectable.
  • app-admin_essentials:3.5.64-2021.2.29 [02-23-2022] - Modified the task query that is used on the Admin Essentials home page.
  • app-automation_catalog:2.11.10-2021.2.11 [03-29-2022] - Fixed a bug that caused the Automation Catalog Collections view to not load (display) when searching for an automation.
  • app-automation_catalog:2.11.10-2021.2.10 [03-21-2022] - Added the Snyk cache file to gitignore.
  • app-automation_catalog:2.11.10-2021.2.7 [02-28-2022] - Fixed a bug in which hardcoded form data for removed fields was sent to the API by manual and scheduled jobs.
  • app-automation_catalog:2.11.10-2021.2.6 [02-24-2022] - Updated usage of internal deprecated APIs.
  • app-automation_studio:3.61.22-2021.2.23 [03-25-2022] - Paginator dropdown is displayed correctly in all collections.
  • app-automation_studio:3.61.22-2021.2.21 [03-21-2022] - Cloned name patterns are now unified among Automation Studio components such as workflows in Gen 2, JSON forms, and templates.
  • app-automation_studio:3.61.22-2021.2.19 [03-07-2022] - Updated rodeo version to fix filtering issue in dropdowns.
  • app-automation_studio:3.61.22-2021.2.18 [02-22-2022] - Fixed a bug that caused an incorrect rendering of fields nested inside of a container when previewing a JSON form.
  • app-configuration_manager:3.90.10-2021.2.36 [03-25-2022] - The Device Template list in the sidebar menu will now update (refresh) when a device template is deleted and remove the deleted template from the list.
  • app-configuration_manager:3.90.10-2021.2.35 [03-24-2022] - Removed the Required and Info buttons for JSON type configurations.
  • app-configuration_manager:3.90.10-2021.2.34 [03-24-2022] - Added a disable feature to the Preview menu option that waits until the preview has completed before enabling reselection. This feature prevents the editor from getting out of sync.
  • app-configuration_manager:3.90.10-2021.2.33 [03-23-2022] - Fixed accordion menu alignment issues when resizing browser window.
  • app-configuration_manager:3.90.10-2021.2.32 [03-23-2022] - Remediation results in Golden Configuration now report accurate information.
  • app-configuration_manager:3.90.10-2021.2.31 [03-18-2022] - Fixed an issue in which Golden Configuration tags were highlighted when comparing configuration differences.
  • app-configuration_manager:3.90.10-2021.2.30 [03-18-2022] - Modified the ConfigModule to allow the user to enter a new line on a new child node that has no existing lines in the configuration.
  • app-configuration_manager:3.90.10-2021.2.29 [03-17-2022] - Corrected a typo in the delete node confirmation pop-up prompt.
  • app-configuration_manager:3.90.10-2021.2.28 [03-17-2022] - Modified the ability to preview configurations for non-JSON configurations in the Golden Configurations.
  • app-configuration_manager:3.90.10-2021.2.27 [03-16-2022] - Fixed invalid configuration of roles app in Configuration Manager.
  • app-configuration_manager:3.90.10-2021.2.24 [02-24-2022] - Updated the PHCodeEditor to use the language property instead of the mode property.
  • app-configuration_manager:3.90.10-2021.2.23 [02-23-2022] - Restricted keyboard shortcuts to protect inherited lines of configuration in the config editor for Golden Configurations.
  • app-configuration_manager:3.90.10-2021.2.22 [02-23-2022] - Added a confirmation pop-up when deleting a Node from the Golden Configuration Tree.
  • app-configuration_manager:3.90.10-2021.2.20 [02-22-2022] - Added a margin-bottom to the node-container to remove unintended text movements while hovering over nodes in the Golden Configuration tab.
  • app-form_builder:4.11.7-2021.2.7 [02-28-2022] - Empty numeric defaults will not be set to zero in forms.
  • app-json_forms:1.33.5-2021.2.8 [03-30-2022] - Fixed a bug that prevented the creation of triggers that use JSON forms in Ops Manager by changing the getForms aggregation pipeline to support the minimum MongoDB version (4.2).
  • app-json_forms:1.33.5-2021.2.7 [03-22-2022] - Tags attribute is added to returned forms objects.
  • app-mop:6.11.8-2021.2.4 [03-11-2022] - DiffConfig task now correctly renders the diff comparison in Job Manager and Ops Manager.
  • app-mop:6.11.8-2021.2.3 [02-24-2022] - Updated the create button, collections button, and transformation links in the navigation bar.
  • app-operations_manager:1.135.13-2021.2.30 [03-25-2022] - Fixed a bug in the Automation Collection view wherein a user was presented with a blank page after deleting all automations. The page is now reset to the previous page once the automations are deleted.
  • app-operations_manager:1.135.13-2021.2.29 [03-24-2022] - Modified the back-end logic on forms saved to automations with a manual or scheduled trigger. This change prevents updated JSON forms from persisting data that was saved previously to the form.
  • app-operations_manager:1.135.13-2021.2.28 [03-21-2022] - Added the ability to initiate a retryable task by clicking on the task summary, description, or task ID in the tasks table.
  • app-operations_manager:1.135.13-2021.2.27 [03-21-2022] - Added the Snyk cache file to gitignore.
  • app-operations_manager:1.135.13-2021.2.26 [03-17-2022] - Fixed a bug that prevented the user from clearing the schema on API and Event triggers.
  • app-operations_manager:1.135.13-2021.2.25 [03-15-2022] - Corrected a bug causing nodes in the Jobs menu to occasionally not display correctly in recent Chrome versions.
  • app-operations_manager:1.135.13-2021.2.24 [03-11-2022] - Added support for cloning automations with API triggers.
  • app-operations_manager:1.135.13-2021.2.23 [03-01-2022] - Fixed pagination logic to allow effective navigation throughout automation list on the left Sidenav bar.
  • app-operations_manager:1.135.13-2021.2.22 [02-24-2022] - Corrected error handling when attempting to run a workflow that referenced a missing JST.
  • app-operations_manager:1.135.13-2021.2.20 [02-18-2022] - Improved event trigger logging in Operations Manager.
  • app-service_catalog:3.11.1-2021.2.2 [03-22-2022] - Added the Snyk cache file to gitignore.
  • app-workflow_builder:5.44.8-2021.2.14 [03-09-2022] - Editing a JST from the childJob task no longer modifies the JST document.
  • app-workflow_builder:5.44.8-2021.2.13 [03-07-2022] - Updated the create and collections button links in the navigation bar.
  • app-workflow_builder:5.44.8-2021.2.12 [02-24-2022] - Title toolbar correctly renders on the right side.
  • app-workflow_engine:9.12.7-2021.2.32 [03-25-2022] - Private variables are no longer available to the task and are filled automatically by the job itself, when required.
  • app-workflow_engine:9.12.7-2021.2.31 [03-22-2022] - Fixed an issue where tasks sent during a RabbitMQ queue connection blockage were getting dropped and hanging while running.
  • app-workflow_engine:9.12.7-2021.2.29 [03-16-2022] - Reverted a code operation that caused missing nested queries to fail the query task.
  • app-workflow_engine:9.12.7-2021.2.22 [03-01-2022] - Added workflow validation for scheduled tasks that have no run window.
  • app-workflow_engine:9.12.7-2021.2.21 [03-01-2022] - Updated getJobList documentation for filter object.
  • app-workflow_engine:9.12.7-2021.2.20 [03-01-2022] - Added support for taking task errors as input in evaluation tasks.
  • pronghorn-core:13.15.17-2021.2.58 [03-25-2022] - Improved the error message that displays when fetching Pre-builts with a proxy. User is now prompted to check proxy settings when unable to get available Pre-builts.
  • pronghorn-core:13.15.17-2021.2.54 [03-23-2022] - Fixed an issue that caused SourceMap warnings to appear in the developer console on several IAP pages.
  • pronghorn-core:13.15.17-2021.2.53 [03-23-2022] - Fixed an issue in the Admin Essentials Alerts dashboard where NaN was displayed for CPU and Memory usage.
  • pronghorn-core:13.15.17-2021.2.50 [03-17-2022] - Added an error return to the Stop and Restart APIs for blocked queue connections.
  • pronghorn-core:13.15.17-2021.2.47 [03-17-2022] - Resolved a bug in form validation by reverting work done previously with respect to when and must conditions.
  • pronghorn-core:13.15.17-2021.2.46 [03-16-2022] - Fixed an issue with JSON schema validation in which encrypted values in profiles with specific formats were handled improperly.
  • pronghorn-core:13.15.17-2021.2.45 [03-16-2022] - Updated the .npmignore file to prevent adding source files into a distribution package.
  • pronghorn-core:13.15.17-2021.2.42 [03-11-2022] - Fixed an issue where services would crash because of a RabbitMQ connection block.
  • pronghorn-core:13.15.17-2021.2.41 [03-10-2022] - Added a validation rule to prevent users from submitting a form with an insufficient number of table elements.
  • pronghorn-core:13.15.17-2021.2.40 [03-09-2022] - Fixed an issue where RabbitMQ connections were not being closed properly.
  • pronghorn-core:13.15.17-2021.2.38 [02-24-2022] - Separated event queue creation and event queue consumption in RabbitMQ.
  • pronghorn-core:13.15.17-2021.2.37 [02-24-2022] - Form export will validate if all the table rows have been filled out.
  • pronghorn-core:13.15.17-2021.2.36 [02-24-2022] - Updated IAP-UI to fix scrolling in the drop down menu.

Security Fixes

  • app-automation_catalog:2.11.10-2021.2.8 [02-28-2022] - Updated Axios to employ security fixes.
  • app-operations_manager:1.135.13-2021.2.21 [02-25-2022] - Updated Axios to capture security fix.
  • pronghorn-core:13.15.17-2021.2.57 [03-24-2022] - Removed unused files to address security vulnerability.
  • pronghorn-core:13.15.17-2021.2.52 [03-23-2022] - Updated the json-pointer dependency to remove a security vulnerability.
  • pronghorn-core:13.15.17-2021.2.43 [03-14-2022] - Updated jQuery to latest version to address a security vulnerability.

Chores

  • adapter-automation_gateway:4.24.1-2021.2.3 [02-24-2022] - Moved project to improved CI pipeline.
  • app-admin_essentials:3.5.64-2021.2.32 [03-03-2022] - Updated the rodeo-ui package dependency to the latest version.
  • app-ag_manager:1.16.1-2021.2.2 [03-07-2022] - Moved project to improved CI pipeline.
  • app-automation_catalog:2.11.10-2021.2.9 [03-03-2022] - Moved project to improved CI pipeline.
  • app-automation_studio:3.61.22-2021.2.22 [03-23-2022] - Improved functionality of dropdown menus in Rodeo. Placeholders are now allowed in dropdown menus and dropdown menus in tables now render correctly.
  • app-automation_studio:3.61.22-2021.2.20 [03-11-2022] - Updated jst-designer dependency to latest version.
  • app-configuration_manager:3.90.10-2021.2.26 [03-16-2022] - Updated @itential/rodeo-ui module to v20.33.2-2021.2.28.
  • app-configuration_manager:3.90.10-2021.2.25 [03-10-2022] - Moved project to improved CI pipeline.
  • app-jst:1.5.18-2021.2.7 [03-11-2022] - Updated jst-designer dependency to latest version.
  • app-service_catalog:3.11.1-2021.2.1 [03-10-2022] - Moved project to improved CI pipeline.
  • app-service_management:2.24.3-2021.2.4 [03-04-2022] - Moved project to improved CI pipeline.
  • app-template_builder:2.6.2-2021.2.1 [02-24-2022] - Moved project to improved pipeline.
  • search:1.1.18-2021.2.4 [03-10-2022] - Moved project to improved CI pipeline.
  • tags:3.1.5-2021.2.2 [03-10-2022] - Moved project to improved CI pipeline.

Tests

  • app-workflow_engine:9.12.7-2021.2.30 [03-17-2022] - Fixed failing assertions for some tests.
  • app-workflow_engine:9.12.7-2021.2.27 [03-10-2022] - Completed the API Test Refactor: test/integration/routes/schema.integrations.name.get.test.js for updated schema changes.
  • app-workflow_engine:9.12.7-2021.2.26 [03-04-2022] - Uncommented test to assert error message.
  • app-workflow_engine:9.12.7-2021.2.25 [03-04-2022] - Added API tests for the runWindow feature in workflows.
  • app-workflow_engine:9.12.7-2021.2.24 [03-04-2022] - Updates test case to pass for task information.
  • app-workflow_engine:9.12.7-2021.2.23 [03-04-2022] - Completed the test refactor for test/api/routes/getJobList.post.js.
  • pronghorn-core:13.15.17-2021.2.51 [03-22-2022] - Completed the api test refactor for API Test Refactor for '88741-introduceAPIsForRepositoryConfigs.test' to fix the test failure.

2021.2.3 Release Versions

Automation Platform Versions

component version
@itential/adapter-automation_gateway 4.24.1-2021.2.4
@itential/adapter-azure_aaa 1.3.2-2021.2.5
@itential/adapter-email 4.2.2-2021.2.5
@itential/adapter-ldap 2.13.1-2021.2.4
@itential/adapter-local_aaa 4.3.1-2021.2.3
@itential/adapter-nso 7.8.2-2021.2.7
@itential/adapter-radius 2.1.1-2021.2.2
@itential/app-admin_essentials 3.5.64-2021.2.36
@itential/app-ag_manager 1.16.1-2021.2.2
@itential/app-automation_catalog 2.11.10-2021.2.11
@itential/app-automation_studio 3.61.22-2021.2.23
@itential/app-configuration_manager 3.90.10-2021.2.36
@itential/app-form_builder 4.11.7-2021.2.7
@itential/app-json_forms 1.33.5-2021.2.8
@itential/app-jst 1.5.18-2021.2.7
@itential/app-mop 6.11.8-2021.2.4
@itential/app-nso_manager 2.23.0-2021.2.2
@itential/app-operations_manager 1.135.13-2021.2.30
@itential/app-service_catalog 3.11.1-2021.2.2
@itential/app-service_management 2.24.3-2021.2.4
@itential/app-template_builder 2.6.2-2021.2.1
@itential/app-workflow_builder 5.44.8-2021.2.15
@itential/app-workflow_engine 9.12.7-2021.2.32
@itential/pronghorn-core 13.15.17-2021.2.58
@itential/search 1.1.18-2021.2.4
@itential/tags 3.1.5-2021.2.2
@itential/itential-utils 2.8.3

Automation Gateway Versions

component version
automation_gateway 3.176.0+2021.2.10

NSO Manager Versions

component version
itential-tools 1.23.35.2021.2.1

Engine Versions

component version
policy-engine 1.10.7+2021.2.1

Dependencies

Automation Platform Server

Package Supported
nodejs >=14.17.3 <15.0.0
npm >=6.14.15 <7.0.0
python >=3.9.5
pip supported
pip >=20.2.4
textfsm >=1.1.2 <1.2.0
Jinja2 >=2.11.3 <2.12.0

The gcc-c++ and make packages should be installed from your OS distribution.

MongoDB Server

Package Supported
mongodb >=5.0.0 <5.1.0

RabbitMQ Server

Package Supported
rabbitmq >=3.8.14 <3.9.0
erlang >=22.3.0 <25.0.0
elixir >=1.10.0 <1.11.0
dedup >=0.5.0 <0.6.0

Redis Server

Package Supported
redis >=5.0.12 <6.0.0

The gcc-c++ and make packages should be installed from your OS distribution.

Hashicorp Vault

Package Supported
vault >=1.0.0 <2.0.0

Automation Gateway

Package Supported
python >=3.9.5 <4.0.0
openssl >=1.1.0 <=1.2.0
haproxy >=2.0.0 <3.0.0

The gcc-c++ and make packages should be installed from your OS distribution.

The following development packages are required to install automation gateway: libffi-dev, openssl-dev, python-dev, sqlite-dev.

pip package Supported
pip 20.2.4
ansible >=2.9.0 <2.11.0
terraform >=0.12.0 <0.13.0
nornir >=3.0.0 <4.0.0
netmiko >=3.0.0 <4.0.0

One or more of the following packages may be required by the specific ansible modules you're using: psutil, pycrypto, paramiko, ncclient, lxml, nitrosdk-python, jxmlease.

Check the ansible documentation for the roles you're planning to use for additional package requirements.

NSO/Itential Tools

Package Supported
java >=1.70 <1.9.0

The ant package should be installed from your OS distribution.

IAP Compatibility

Device Configuration

Device Configuration compatibility describes which devices are expected to work with the basic features of the Configuration Manager application across various southbound systems.

Ansible:

* Arista EOS
* Cisco IOS
* Cisco IOSXR
* Cisco NX
* Juniper Junos

NSO:

Refer to the NSO Versions and NED Versions tables below for a list of tested devices.

Device Compliance

Device Compliance compatibility describes which devices are expected to work with Golden Configurations.

Ansible:

* Arista EOS
* Cisco IOS
* Cisco IOSXR
* Cisco NX
* Juniper Junos

NSO (Configuration Manager app):

* Arista EOS
* Cisco IOS
* Cisco IOSXR
* Cisco NX
* Juniper Junos

Device Maintenance

Device Maintenance compatibility describes which devices Itential can perform maintenance activities on (e.g., reboots and firmware upgrades).

Ansible:

* Arista EOS
* Cisco IOS
* Cisco IOSXR
* Juniper Junos

NSO:

* cisco-ios
* cisco-iosxr
* juniper-junos

Device Health Checks

Device Health Checks compatibility describes which devices Itential can execute read-only show commands to use the method broker and Command Templates application.

Ansible:

* Arista EOS
* Cisco IOS
* Cisco IOSXR
* Cisco NX
* Juniper Junos

NSO:

* a10-acos
* alu-sr
* arista-dcs
* cienacli-acos
* cisco-aireos
* cisco-asa
* cisco-gss
* cisco-ios
* cisco-iosxr
* cisco-nx
* cisco-qps
* cisco-staros
* ericsson-sgsnmme
* f5-bigip
* huawei-vrp
* juniper-junos

Note: Some of the devices in the health checks category are tested against netsim devices.

Forms

Ansible:

IAP can render most ansible networking modules as forms. Support for specific modules may vary. If you encounter issues with any particular modules, reach out to the Itential Customer Success Team for assistance.

NSO:

IAP can render most service models advertised by NSO as forms. Support for specific yang features may vary. If you encounter issues with your service models, reach out to the Itential Customer Success Team for assistance.

Service Provisioning

NSO:

IAP can provision most service models advertised by NSO. Support for specific yang features may vary. If you encounter issues with your service models, reach out to the Itential Customer Success Team for assistance.

Devices/Services Compatibility

The Itential Automation Platform is tested against the following component versions.

Ansible Versions:

* 2.10.7
* 2.9.27

Ansible Modules:

* eos_facts
* eos_command
* eos_config
* ios_facts
* ios_command
* ios_config
* iosxr_facts
* iosxr_command
* iosxr_config
* nx_facts
* nx_command
* nx_config
* junos_facts
* junos_command
* junos_config

NSO Versions:

* 5.4.4
* 5.5.1
* 5.6
* 5.7

NSO NED Versions:

ned 5.4.4 5.5.1 5.6
a10-acos 3.18 3.18 3.18
adtran-aos 4.0.6 4.0.6 4.0.6
alu-sr 8.13.4 8.13.4
8.13.3
8.13.3
6.13.4
8.21
arista-dcs 5.20.2 5.20.2
5.20
5.20.2
5.23
checkpoint-gaiaos_rest n/a 1.10.7
1.10.6
1.10.7
1.10.6
1.10.22
ciena-acos 6.2.5 6.2.5
6.2.4
6.2.4
6.2.5
6.4
cisco-aireos 3.7.2
3.7.1
3.7.2
3.7.1
3.7.1
3.7.2
3.9.3
cisco-asa 6.12.4 6.12.4
6.12.3
6.12.3
6.12.4
6.13.6
cisco-gss 2.1.1 2.1.1 2.1.1
cisco-ios 6.69
6.68.2
6.69
6.68.2
6.68.2
6.72.2
6.74.11
cisco-iosxr 7.33 7.33
7.32.5
7.32.5
7.33
7.36
cisco-nx 5.21.1 5.21.1
5.21
5.21.1
5.22.1
cisco-qps 5.1.3 5.1.3 5.1.3
5.1.7
cisco-staros 5.34.6
5.34.5
5.34.6
5.34.5
5.34.5
5.34.6
5.41.1
ericsson-sgsnmme 1.0.7 n/a n/a
f5-bigip 3.17
3.16
3.17
3.16
3.16
3.17
3.21.1
fortinet-fortios 5.4.21 5.4.21
5.4.20
5.4.20
5.4.21
5.5
huawei-usn 1.2.1 n/a n/a
huawei-vrp 6.17.4
6.17.3
6.17.4
6.17.3
6.17.3
6.17.4
6.26.8
juniper-junos 4.6.19
4.6.17
4.6.19
4.6.17
4.6.19
4.6.23
4.6.33
paloalto-panos_cli 4.8.2
4.8.1
4.8.2
4.8.1
4.8.2
4.8.1
4.8.8
radware-alteonos 2.4.1 2.4.1
2.4
2.4.1
2.4
unix-bind 2.1.0 2.1.0 2.1.0
2.1.3

VTS Versions:

* 2.6.2

VTS NED Versions:

ned 2.6.2
cisco-iosxr 6.6
cisco-ncs5500 1.0
cisco-nx 5.1.4

Virtual Devices:

* A10 vThunder 4.1.4 GR1
* Arista EOS-4.23.0FX
* Checkpoint R80.30-273.583
* Cisco ASAv 9.13.1.7
* Cisco CSR 17.02.01r
* Cisco NX 9.3.2, 9.3.1
* Cisco StarOS 21.15.29
* Cisco XR6.3.1
* F5 BIGIP 15.1.0.2-0.0.9
* Fortigate 6.4.0
* Juniper VMX 18.4R1
* Juniper VSRX 19.1R2
* PanOS 9.1.2
* Radware 32.6.0.0

IAP Browser Compatibility

This maintenance release was tested against the following browser versions:

* Firefox 89
* Chrome 91.0.4472.77
* Edge 91.0.864.37
* Internet Explorer 11