Supported NSO Versions
  • Dark
    Light
  • PDF

Supported NSO Versions

  • Dark
    Light
  • PDF

Itential supports the use of a variety of third-party integrations to further enhance the capabilities of Itential Automation Platform (IAP). Cisco Network Services Orchestrator (NSO) is one such integration. To ensure that NSO functions as intended, it is important to understand which NSO versions are supported for each IAP version. This document provides information to help you determine which version of NSO is compatible with your IAP environment.

NSO Support Policy

The Itential platform supports integration with tested and verified versions of NSO, which may vary for each version of IAP. To this end, Itential will address any errors or flaws that affect the integration of supported NSO versions into IAP. All patch releases (denoted by the third digit in the NSO version number) for supported NSO versions are covered by this policy.

⚠ Itential is not responsible for the development or support of NSO itself.

Versions Currently Supported

Supported versions of NSO are defined in the Release Notes of each version of IAP. In the Devices/Services Compatibility section of the release notes, the NSO versions used for testing are listed in the NSO Versions table. When viewing this table, note that the support policy defined above applies. Though a specific patch release for each NSO version may be listed in the table, any patch release for that NSO version is supported.

⚠ When planning to integrate NSO into IAP, keep long-term support (LTS) versions of NSO in mind. Details regarding the support of LTS versions of NSO can be found in the next section.

Planned Future Support

The following sections outline planned support for NSO that Itential is targeting for the future. As new versions of IAP and NSO are released, testing will be required before certifying support.

Aligning With Cisco Support

Moving forward, Itential will support any version of NSO that is supported by Cisco at that time, including LTS versions of NSO. For further information about the NSO version lifecycle, refer to the Cisco End-of-Life and End-of-Sale Notices.

Backporting Support

Whenever a new version of NSO is released by Cisco, Itential will attempt to certify support of that NSO version for the latest existing release of IAP.

NSO Version Support

Version 2021.2.x 2022.1.x 2022.2.x 2023.1.x 2023.2.x 2024.1.x 2024.2.x 2025.1.x 2025.2.x
5.5.x
5.6.x
5.7.x (LTS)
5.8.x [1] ✓ [2]
6.0.x [1] ✓ [2]
6.1.x (LTS) [1] ✓ [2]
6.2.x [1] ✓ [2]
6.3.x [1] ✓ [2]

Footnotes

[1] NSO version numbers that are forecasted for release in the future are subject to change.

[2] IAP support for this future version of NSO will be backported once the NSO version is released by Cisco.


Changing your password will log you out immediately. Use the new password to log back in.
First name must have atleast 2 characters. Numbers and special characters are not allowed.
Last name must have atleast 1 characters. Numbers and special characters are not allowed.
Enter a valid email
Enter a valid password
Your profile has been successfully updated.