Release Versions & Dependencies
  • Dark
    Light
  • PDF

Release Versions & Dependencies

  • Dark
    Light
  • PDF

2022.1.1 Release Versions

Automation Platform Versions

component version
@itential/adapter-automation_gateway 4.26.1-2022.1.1
@itential/adapter-azure_aaa 1.4.2-2022.1.0
@itential/adapter-email 4.2.8-2022.1.4
@itential/adapter-ldap 2.13.8-2022.1.0
@itential/adapter-local_aaa 4.3.6-2022.1.0
@itential/adapter-nso 7.8.20-2022.1.3
@itential/adapter-radius 2.1.7-2022.1.0
@itential/app-admin_essentials 3.13.12-2022.1.7
@itential/app-ag_manager 1.18.3-2022.1.0
@itential/app-automation_catalog 2.12.11-2022.1.0
@itential/app-automation_studio 4.1.2-2022.1.17
@itential/app-configuration_manager 3.97.6-2022.1.6
@itential/app-form_builder 4.11.26-2022.1.0
@itential/app-json_forms 1.34.12-2022.1.3
@itential/app-jst 1.8.5-2022.1.5
@itential/app-mop 6.11.25-2022.1.2
@itential/app-nso_manager 2.23.3-2022.1.0
@itential/app-operations_manager 1.171.4-2022.1.16
@itential/app-service_catalog 3.12.0-2022.1.0
@itential/app-service_management 2.24.9-2022.1.1
@itential/app-template_builder 2.6.7-2022.1.0
@itential/app-workflow_builder 5.44.64-2022.1.9
@itential/app-workflow_engine 9.13.31-2022.1.3
@itential/pronghorn-core 13.28.27-2022.1.13
@itential/search 1.1.25-2022.1.0
@itential/tags 3.1.12-2022.1.0
@itential/itential-utils 2.9.4

Automation Gateway Versions

component version
automation_gateway 3.198.19+2022.1.4

NSO Manager Versions

component version
itential-tools 1.23.42.2022.1.0

Engine Versions

component version
policy-engine 1.10.8+2022.1.0

Dependencies

Automation Platform Server

Package Supported
nodejs >=14.18.2 <15.0.0
npm >=6.14.15 <7.0.0
python >=3.9.5
pip supported
pip >=20.2.4
textfsm >=1.1.2 <1.2.0
Jinja2 >=2.11.3 <2.12.0

The gcc-c++ and make packages should be installed from your OS distribution.

MongoDB Server

Package Supported
mongodb >=5.0.0 <5.1.0

RabbitMQ Server

Package Supported
rabbitmq >=3.8.14 <3.9.0
erlang >=22.3.0 <25.0.0
elixir >=1.10.0 <1.11.0
dedup >=0.5.0 <0.6.0

Redis Server

Package Supported
redis >=5.0.12 <6.0.0

The gcc-c++ and make packages should be installed from your OS distribution.

Hashicorp Vault

Package Supported
vault >=1.0.0 <2.0.0

Automation Gateway

Package Supported
python >=3.9.5 <4.0.0
openssl >=1.1.0 <=1.2.0
haproxy >=2.0.0 <3.0.0

The gcc-c++ and make packages should be installed from your OS distribution.

The following development packages are required to install automation gateway: libffi-dev, openssl-dev, python-dev, sqlite-dev.

pip package Supported
pip 20.2.4
ansible >=2.9.0 <2.11.0
terraform >=0.12.0 <0.13.0
nornir >=3.0.0 <4.0.0
netmiko >=3.0.0 <4.0.0

One or more of the following packages may be required by the specific ansible modules you're using: psutil, pycrypto, paramiko, ncclient, lxml, nitrosdk-python, jxmlease.

Check the ansible documentation for the roles you're planning to use for additional package requirements.

NSO/Itential Tools

Package Supported
java >=1.70 <1.9.0

The ant package should be installed from your OS distribution.


Changing your password will log you out immediately. Use the new password to log back in.
First name must have atleast 2 characters. Numbers and special characters are not allowed.
Last name must have atleast 1 characters. Numbers and special characters are not allowed.
Enter a valid email
Enter a valid password
Your profile has been successfully updated.