Product Notices

On this page:

Version Lifecycle

Version Lifecycle

Itential is always improving and updating software, and to provide our customers with the latest in network automation, all of our software versions have a designated lifecycle. A natural part of this is to shift our developer focus toward features and enhancements that utilize newer technologies to ensure all our products are cutting edge.

Maintenance Releases

Maintenance Releases are scheduled for availability on the 1st Tuesday of every month during a major version lifecycle. If that day should fall on a holiday, the release will be rescheduled for the next business day.

End of Support

After two years, a major software version reaches its End-of-Support (EOS) date. Once the software reaches EOS, Itential will no longer accept support tickets related to the version, and Maintenance Releases for the version will cease to be published.

Release Version Release Date End of Support
PH5 Sep 4, 2017 Dec 29, 2019
2018.3 (PH6) Nov 9, 2018 Nov 9, 2020
2019.1 Apr 1, 2019 Apr 1, 2021
2019.2 Aug 2, 2019 Aug 2, 2021
2019.3 Dec 6, 2019 Dec 6, 2021
2020.1 Apr 24, 2020 Apr 25, 2022
2020.2 Jan 5, 2021 Jan 5, 2023
2021.1 June 25, 2021 June 25, 2023
2021.2 Jan 24, 2022 Jan 24, 2024


Nexus Repository Retention

Itential will periodically remove software from the Nexus Repository if it has reached its End of Support lifecycle.

Third-Party Integrations

All third-party software version compatibility is documented in Release Notes. To get the most up-to-date requirements for any third-party integration, including open source, first identify the IAP release version you are using and then refer to the respective release note.

When a third-party integration has reached obsolescence on the Itential platform, it will no longer be actively supported by the Service Desk. For customers with unsupported third party integrations, Itential may provide limited assistance, where possible, but no bug fixes, workarounds or patches will be provided. As such, the end user will need to upgrade to the newest version of the integration in accordance with version compatibility documented in Release Notes.